Re: [PATCH net-next 3/8] net: caif: use max() to simplify the code

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Aug 22, 2024 at 09:39:03PM +0800, Li Zetao wrote:
> When processing the tail append of sk buffer, the final length needs
> to be determined based on expectlen and addlen. Using max() here can
> increase the readability of the code.
> 
> Signed-off-by: Li Zetao <lizetao1@xxxxxxxxxx>
> ---
>  net/caif/cfpkt_skbuff.c | 6 ++----
>  1 file changed, 2 insertions(+), 4 deletions(-)
> 
> diff --git a/net/caif/cfpkt_skbuff.c b/net/caif/cfpkt_skbuff.c
> index 2ae8cfa3df88..96236d21b18e 100644
> --- a/net/caif/cfpkt_skbuff.c
> +++ b/net/caif/cfpkt_skbuff.c
> @@ -298,10 +298,8 @@ struct cfpkt *cfpkt_append(struct cfpkt *dstpkt,
>  	if (unlikely(is_erronous(dstpkt) || is_erronous(addpkt))) {
>  		return dstpkt;
>  	}
> -	if (expectlen > addlen)
> -		neededtailspace = expectlen;
> -	else
> -		neededtailspace = addlen;
> +
> +	neededtailspace = max(expectlen, addlen);

The types of all three variables involved here are u16,
so this looks correct to me. And the code replaced
seems to be an open coding of max() both in intent and function.

Reviewed-by: Simon Horman <horms@xxxxxxxxxx>

>  
>  	if (dst->tail + neededtailspace > dst->end) {
>  		/* Create a dumplicate of 'dst' with more tail space */




[Index of Archives]     [Bluez Devel]     [Linux Wireless Networking]     [Linux Wireless Personal Area Networking]     [Linux ATH6KL]     [Linux USB Devel]     [Linux Media Drivers]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Big List of Linux Books]

  Powered by Linux