On Tue, Feb 08, 2011, Sheldon Demario wrote: > +int do_interactive(void); I don't really like having an exported function called do_*. The places I've seen this naming convention have usually been when there's some other function already with the name you want and in all places the do_ variant is static. How about simply interactive() or interactive_mode(). Also, shouldn't you be passing the minimum config options as parameters to this function? Otherwise you'll have to have some sort of global config variables. > +++ b/attrib/igatttool.c Since we don't have igattool anymore, how about calling this interactive.c? > +static void cmd_help(int argcp, char **argvp); > +static void cmd_exit(int argcp, char **argvp); No forward-declarations please. Just reorder the functions so that you don't need to do this. Johan -- To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html