Re: [patch 1/3] hci_usb: do not initialize static variables to 0

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Andrew,

hci_usb: do not initialize static variables to 0.

Signed-off-by: Pavel Machek <pavel@xxxxxxx>
Cc: Marcel Holtmann <marcel@xxxxxxxxxxxx>
Cc: Dave Young <hidave.darkstar@xxxxxxxxx>
Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx>
---

drivers/bluetooth/hci_usb.c |   14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)

diff -puN drivers/bluetooth/hci_usb.c~hci_usb-do-not-initialize- static-variables-to-0 drivers/bluetooth/hci_usb.c --- a/drivers/bluetooth/hci_usb.c~hci_usb-do-not-initialize-static- variables-to-0
+++ a/drivers/bluetooth/hci_usb.c
@@ -62,13 +62,13 @@
#define URB_ZERO_PACKET 0
#endif

-static int ignore = 0;
-static int ignore_dga = 0;
-static int ignore_csr = 0;
-static int ignore_sniffer = 0;
-static int disable_scofix = 0;
-static int force_scofix = 0;
-static int reset = 0;
+static int ignore;
+static int ignore_dga;
+static int ignore_csr;
+static int ignore_sniffer;
+static int disable_scofix;
+static int force_scofix;
+static int reset;

I know that some people don't like to do it and I agree, but in case of module parameters, I prefer to have them clearly indicate what the default value is. It is a lot easier to read for other people looking at the code. So that one is a NAK from my side.

Regards

Marcel

--
To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Bluez Devel]     [Linux Wireless Networking]     [Linux Wireless Personal Area Networking]     [Linux ATH6KL]     [Linux USB Devel]     [Linux Media Drivers]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Big List of Linux Books]

  Powered by Linux