On 4/12/23 14:32, Christoph Hellwig wrote: > Split the RQF_DONTPREP and RQF_SOFTBARRIER in separate branches to make > the code more readable. > > Signed-off-by: Christoph Hellwig <hch@xxxxxx> > Reviewed-by: Bart Van Assche <bvanassche@xxxxxxx> > --- > block/blk-mq.c | 14 +++++++------- > 1 file changed, 7 insertions(+), 7 deletions(-) > > diff --git a/block/blk-mq.c b/block/blk-mq.c > index c3de03217f4f1a..5dfb927d1b9145 100644 > --- a/block/blk-mq.c > +++ b/block/blk-mq.c > @@ -1427,20 +1427,20 @@ static void blk_mq_requeue_work(struct work_struct *work) > spin_unlock_irq(&q->requeue_lock); > > list_for_each_entry_safe(rq, next, &rq_list, queuelist) { > - if (!(rq->rq_flags & (RQF_SOFTBARRIER | RQF_DONTPREP))) > - continue; > - > - rq->rq_flags &= ~RQF_SOFTBARRIER; > - list_del_init(&rq->queuelist); > /* > * If RQF_DONTPREP, rq has contained some driver specific Nit: while at it, you could fix the bad english here: rq has contained som... -> rq has some... Otherwise looks good. Reviewed-by: Damien Le Moal <dlemoal@xxxxxxxxxx>