On Fri, Nov 04, 2022 at 12:23:07AM -0700, Eric Biggers wrote: > > +bool blk_crypto_cfg_supported(struct block_device *bdev, > > + const struct blk_crypto_config *cfg) > > +{ > > + return __blk_crypto_cfg_supported(bdev_get_queue(bdev)->crypto_profile, > > + cfg); > > +} > > I think this part is too confusing, because there's already a function > blk_crypto_config_supported() which does something slightly different. > > How about calling this blk_crypto_config_supported_natively() instead? It's > kind of long, but it's much clearer. Fine with me. > Also, it should be defined in blk-crypto.c, next to > blk_crypto_config_supported(), and not in blk-crypto-profile.c. > (And declared in blk-crypto.h, not blk-crypto-profile.h.) Ok.