Use eq for the elevator_queue as done elsewhere. This frees e to be used for the loop iterator instead of the odd __ prefix. In addition rename elv to cur to make it more clear it is the currently selected elevator. Signed-off-by: Christoph Hellwig <hch@xxxxxx> --- block/elevator.c | 17 ++++++++--------- 1 file changed, 8 insertions(+), 9 deletions(-) diff --git a/block/elevator.c b/block/elevator.c index 92096e5aabd36..4fc0d2f539295 100644 --- a/block/elevator.c +++ b/block/elevator.c @@ -772,9 +772,8 @@ ssize_t elv_iosched_store(struct request_queue *q, const char *buf, ssize_t elv_iosched_show(struct request_queue *q, char *name) { - struct elevator_queue *e = q->elevator; - struct elevator_type *elv = NULL; - struct elevator_type *__e; + struct elevator_queue *eq = q->elevator; + struct elevator_type *cur = NULL, *e; int len = 0; if (!elv_support_iosched(q)) @@ -783,17 +782,17 @@ ssize_t elv_iosched_show(struct request_queue *q, char *name) if (!q->elevator) len += sprintf(name+len, "[none] "); else - elv = e->type; + cur = eq->type; spin_lock(&elv_list_lock); - list_for_each_entry(__e, &elv_list, list) { - if (elv && elevator_match(elv, __e->elevator_name, 0)) { - len += sprintf(name+len, "[%s] ", elv->elevator_name); + list_for_each_entry(e, &elv_list, list) { + if (cur && elevator_match(cur, e->elevator_name, 0)) { + len += sprintf(name+len, "[%s] ", cur->elevator_name); continue; } - if (elevator_match(__e, __e->elevator_name, + if (elevator_match(e, e->elevator_name, q->required_elevator_features)) - len += sprintf(name+len, "%s ", __e->elevator_name); + len += sprintf(name+len, "%s ", e->elevator_name); } spin_unlock(&elv_list_lock); -- 2.30.2