Re: [PATCH linux-next] null_blk: use sysfs_emit() to instead of scnprintf()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 10/21/22 17:54, yexingchen116@xxxxxxxxx wrote:
> From: ye xingchen <ye.xingchen@xxxxxxxxxx>
> 
> Replace the open-code with sysfs_emit() to simplify the code.
> 
> Signed-off-by: ye xingchen <ye.xingchen@xxxxxxxxxx>

Reviewed-by: Damien Le Moal <damien.lemoal@xxxxxxxxxxxxxxxxxx>

> ---
>  drivers/block/null_blk/main.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/block/null_blk/main.c b/drivers/block/null_blk/main.c
> index 1f154f92f4c2..5317ef2ba227 100644
> --- a/drivers/block/null_blk/main.c
> +++ b/drivers/block/null_blk/main.c
> @@ -255,18 +255,18 @@ static inline struct nullb_device *to_nullb_device(struct config_item *item)
>  
>  static inline ssize_t nullb_device_uint_attr_show(unsigned int val, char *page)
>  {
> -	return snprintf(page, PAGE_SIZE, "%u\n", val);
> +	return sysfs_emit(page, "%u\n", val);
>  }
>  
>  static inline ssize_t nullb_device_ulong_attr_show(unsigned long val,
>  	char *page)
>  {
> -	return snprintf(page, PAGE_SIZE, "%lu\n", val);
> +	return sysfs_emit(page, "%lu\n", val);
>  }
>  
>  static inline ssize_t nullb_device_bool_attr_show(bool val, char *page)
>  {
> -	return snprintf(page, PAGE_SIZE, "%u\n", val);
> +	return sysfs_emit(page, "%u\n", val);
>  }
>  
>  static ssize_t nullb_device_uint_attr_store(unsigned int *val,

-- 
Damien Le Moal
Western Digital Research




[Index of Archives]     [Linux RAID]     [Linux SCSI]     [Linux ATA RAID]     [IDE]     [Linux Wireless]     [Linux Kernel]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Device Mapper]

  Powered by Linux