On Wed, Oct 05, 2022 at 06:45:35PM +0000, Chaitanya Kulkarni wrote: > > >> @@ -875,6 +877,24 @@ static void null_free_sector(struct nullb *nullb, sector_t sector, > >> } > >> } > >> > >> +static void null_zero_sector(struct nullb_device *d, sector_t sect, > >> + sector_t nr_sects, bool cache) > >> +{ > > > > Any reason to not just pass the tree root directly here instead of the > > cache boolean? It might make the callers more readable and also > > eliminates the need to pass the nullb_device. > > > > Brian > > > > I kept the style similar to null_free_sector() where root is calculated > inside the helper acting on the sector, if we change that for > null_zero_sector() then I think we need to change for null_free_sector() > for consistency, unless you strongly object it for some reason. > Nope, just a nit that stood out to me when skimming the patches. Not a big deal at all. Brian > -ck >