Re: [PATCH 1/6] block: change the blk_queue_split calling convention

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 7/27/22 18:22, Christoph Hellwig wrote:
The double indirect bio leads to somewhat suboptimal code generation.
Instead return the (original or split) bio, and make sure the
request_queue arguments to the lower level helpers is passed after the
bio to avoid constant reshuffling of the argument passing registers.

Also give it and the helpers used to implement it more descriptive names.

Signed-off-by: Christoph Hellwig <hch@xxxxxx>
---
  block/blk-merge.c             | 98 +++++++++++++++++------------------
  block/blk-mq.c                |  4 +-
  block/blk.h                   |  6 +--
  drivers/block/drbd/drbd_req.c |  2 +-
  drivers/block/pktcdvd.c       |  2 +-
  drivers/block/ps3vram.c       |  2 +-
  drivers/md/dm.c               |  6 +--
  drivers/md/md.c               |  2 +-
  drivers/nvme/host/multipath.c |  2 +-
  drivers/s390/block/dcssblk.c  |  2 +-
  include/linux/blkdev.h        |  2 +-
  11 files changed, 63 insertions(+), 65 deletions(-)

Reviewed-by: Hannes Reinecke <hare@xxxxxxx>

Cheers,

Hannes
--
Dr. Hannes Reinecke		           Kernel Storage Architect
hare@xxxxxxx			                  +49 911 74053 688
SUSE Software Solutions Germany GmbH, Maxfeldstr. 5, 90409 Nürnberg
HRB 36809 (AG Nürnberg), GF: Felix Imendörffer



[Index of Archives]     [Linux RAID]     [Linux SCSI]     [Linux ATA RAID]     [IDE]     [Linux Wireless]     [Linux Kernel]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Device Mapper]

  Powered by Linux