Re: [PATCH 1/6] block: change the blk_queue_split calling convention

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, 27 Jul 2022 12:22:55 -0400, Christoph Hellwig wrote:
> The double indirect bio leads to somewhat suboptimal code generation.
> Instead return the (original or split) bio, and make sure the
> request_queue arguments to the lower level helpers is passed after the
> bio to avoid constant reshuffling of the argument passing registers.
> 
> Also give it and the helpers used to implement it more descriptive names.
> 
> [...]

Applied, thanks!

[1/6] block: change the blk_queue_split calling convention
      commit: b1b9c6f4d078f50b62e8cc0f4d3bd4c87d411377
[2/6] block: change the blk_queue_bounce calling convention
      commit: 4d70e071de1fe363e81fdfd7b0b1686355120fdb
[3/6] block: move ->bio_split to the gendisk
      commit: 1be3479b85330141b54a102903e5f07948362695
[4/6] block: move the call to get_max_io_size out of blk_bio_segment_split
      commit: 0ef1e5aa4337e291e9fe590e01e1da3021be6743
[5/6] block: move bio_allowed_max_sectors to blk-merge.c
      commit: fa785c340621a4da8f6ee70b6e5ad263c4c4bbb5
[6/6] block: pass struct queue_limits to the bio splitting helpers
      commit: c9ca8dcc66a99d1123f0fdc2dc161436b93d194b

Best regards,
-- 
Jens Axboe





[Index of Archives]     [Linux RAID]     [Linux SCSI]     [Linux ATA RAID]     [IDE]     [Linux Wireless]     [Linux Kernel]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Device Mapper]

  Powered by Linux