Re: [PATCH 1/6] block: change the blk_queue_split calling convention

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, 26 Jul 2022 14:30:24 -0400, Christoph Hellwig wrote:
> The double indirect bio leads to somewhat suboptimal code generation.
> Instead return the (original or split) bio, and make sure the
> request_queue arguments to the lower level helpers is passed after the
> bio to avoid constant reshuffling of the argument passing registers.
> 
> Also give it and the helpers used to implement it more descriptive names.
> 
> [...]

Applied, thanks!

[1/6] block: change the blk_queue_split calling convention
      commit: ab3b67b638fe2f99eae85935650e033d07fb1c2a
[2/6] block: change the blk_queue_bounce calling convention
      commit: c822f1c10f6cffc444ce2b998ee9969c02a172e8
[3/6] block: move ->bio_split to the gendisk
      commit: 8ecf459ff220c90dc11960524d38dd59472c169e
[4/6] block: move the call to get_max_io_size out of blk_bio_segment_split
      commit: 34c0966ec6710bb65db375dd717a1e3e02bf9bfa
[5/6] block: move bio_allowed_max_sectors to blk-merge.c
      commit: bb9f90089379540f8935ff5d705faa4b32531f8a
[6/6] block: pass struct queue_limits to the bio splitting helpers
      commit: 1e58f07b91f50fc6b50d82e6d4075923c511b9a2

Best regards,
-- 
Jens Axboe





[Index of Archives]     [Linux RAID]     [Linux SCSI]     [Linux ATA RAID]     [IDE]     [Linux Wireless]     [Linux Kernel]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Device Mapper]

  Powered by Linux