Re: [RFC PATCH 3/3] scsi, usb: storage: Complete the blk-request directly.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 10/15/21 08:14, Sebastian Andrzej Siewior wrote:
+static inline void scsi_done(struct scsi_cmnd *scmd)
+{
+	scmd->scsi_done(scmd);
+}

How about leaving out this function definition and open-coding it into its callers?

Additionally, please rebase this patch series on top of "[PATCH v3 00/88] Call scsi_done() directly" (https://lore.kernel.org/linux-scsi/20211007202923.2174984-1-bvanassche@xxxxxxx/ or https://github.com/bvanassche/linux/tree/scsi-remove-done-callback). Otherwise Linus will have to resolve a very complicated merge conflict.

Thank you,

Bart.



[Index of Archives]     [Linux RAID]     [Linux SCSI]     [Linux ATA RAID]     [IDE]     [Linux Wireless]     [Linux Kernel]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Device Mapper]

  Powered by Linux