On Sat, Oct 09, 2021 at 10:33:17AM -0600, Jens Axboe wrote: > > +static inline struct block_device *blkdev_get_bdev(struct file *file) > > +{ > > + return file->private_data; > > +} > > Get rid of this and just use bdev = file->private_data where > appropriate. Easier to read, we don't need to hide this in a function. 100% agreed.