On 2021/08/11 12:37, Damien Le Moal wrote: > This series fixes problems with IO priority values handling and cleans > up several macro names and code for clarity. Jens, Any comment on this ? > > Changes from v3: > * Split former patch 2 into patches 2, 3 and 4 to facilitate review and > have more descriptive commit titles. > * In patch 5, keep IOPRIO_BE_NR as an alias for the new IOPRIO_NR_LEVELS > macro. Change this patch title and commit message accordingly. > * In patch 6, define IOPRIO_BE_NORM as an alias of IOPRIO_NORM. > > Changes from v2: > * Fixed typo in a comment in patch 3 > * Added reviewed-by tags > > Changes from v1: > * Added patch 4 to unify the default priority value used in various > places. > * Fixed patch 2 as suggested by Bart: remove extra parenthesis and move > ioprio_valid() from the uapi header to the kernel header. > * In patch 2, add priority value masking. > > Damien Le Moal (6): > block: bfq: fix bfq_set_next_ioprio_data() > block: improve ioprio class description comment > block: change ioprio_valid() to an inline function > block: fix IOPRIO_PRIO_CLASS() and IOPRIO_PRIO_VALUE() macros > block: Introduce IOPRIO_NR_LEVELS > block: fix default IO priority handling > > block/bfq-iosched.c | 10 +++++----- > block/bfq-iosched.h | 4 ++-- > block/bfq-wf2q.c | 6 +++--- > block/ioprio.c | 9 ++++----- > drivers/nvme/host/lightnvm.c | 2 +- > fs/f2fs/sysfs.c | 2 +- > include/linux/ioprio.h | 17 ++++++++++++++++- > include/uapi/linux/ioprio.h | 34 ++++++++++++++++++++-------------- > 8 files changed, 52 insertions(+), 32 deletions(-) > -- Damien Le Moal Western Digital Research