On Thu, Jun 17, 2021 at 05:44:48PM -0700, Bart Van Assche wrote: > Change "queue" into "sched" to make the function names reflect better the > purpose of these functions. > > Reviewed-by: Chaitanya Kulkarni <chaitanya.kulkarni@xxxxxxx> > Reviewed-by: Damien Le Moal <damien.lemoal@xxxxxxx> > Reviewed-by: Hannes Reinecke <hare@xxxxxxx> > Reviewed-by: Johannes Thumshirn <johannes.thumshirn@xxxxxxx> > Reviewed-by: Himanshu Madhani <himanshu.madhani@xxxxxxxxxx> > Cc: Damien Le Moal <damien.lemoal@xxxxxxx> > Cc: Christoph Hellwig <hch@xxxxxx> > Cc: Ming Lei <ming.lei@xxxxxxxxxx> > Signed-off-by: Bart Van Assche <bvanassche@xxxxxxx> > --- > block/mq-deadline.c | 8 ++++---- > 1 file changed, 4 insertions(+), 4 deletions(-) > > diff --git a/block/mq-deadline.c b/block/mq-deadline.c > index caa438f62a4d..d823ba7cb084 100644 > --- a/block/mq-deadline.c > +++ b/block/mq-deadline.c > @@ -395,7 +395,7 @@ static struct request *dd_dispatch_request(struct blk_mq_hw_ctx *hctx) > return rq; > } > > -static void dd_exit_queue(struct elevator_queue *e) > +static void dd_exit_sched(struct elevator_queue *e) > { > struct deadline_data *dd = e->elevator_data; > > @@ -408,7 +408,7 @@ static void dd_exit_queue(struct elevator_queue *e) > /* > * initialize elevator private data (deadline_data). > */ > -static int dd_init_queue(struct request_queue *q, struct elevator_type *e) > +static int dd_init_sched(struct request_queue *q, struct elevator_type *e) > { > struct deadline_data *dd; > struct elevator_queue *eq; > @@ -800,8 +800,8 @@ static struct elevator_type mq_deadline = { > .requests_merged = dd_merged_requests, > .request_merged = dd_request_merged, > .has_work = dd_has_work, > - .init_sched = dd_init_queue, > - .exit_sched = dd_exit_queue, > + .init_sched = dd_init_sched, > + .exit_sched = dd_exit_sched, > }, > > #ifdef CONFIG_BLK_DEBUG_FS Looks good. Reviewed by: Adam Manzanares <a.manzanares@xxxxxxxxxxx>