On 11/17/20 6:06 AM, Luis Chamberlain wrote: > Commit b5bd357cf8b ("block: add docs for gendisk / request_queue refcount > helpers") has a typo where it references drivers for del_gendisk() when we > instead meant userspace, as the reference is to the userspace experience. > This fixes this. > > Signed-off-by: Luis Chamberlain <mcgrof@xxxxxxxxxx> > --- > block/genhd.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/block/genhd.c b/block/genhd.c > index 0a273211fec2..9511620f558a 100644 > --- a/block/genhd.c > +++ b/block/genhd.c > @@ -880,8 +880,8 @@ static void invalidate_partition(struct gendisk *disk, int partno) > * with put_disk(), which should be called after del_gendisk(), if > * __device_add_disk() was used. > * > - * Drivers exist which depend on the release of the gendisk to be synchronous, > - * it should not be deferred. > + * Userspace may exist which depends on the release of the gendisk to be > + * synchronous, it should not be deferred. Please change "may exist which depends" into "software may depend" to make the comment easier to understand. Thanks, Bart.