From: Javier González <javier.gonz@xxxxxxxxxxx> This series enables a per-namespace char device that is always presented to the host, independently of the block device associated with the namespace. This allows user-space to use the char device's IOCTL interface when the kernel rejects the block device due to unsupported features. Examples of these features include unsupported PI configurations, ZNS features such as zoc, or unsupported command sets such as KV. One of the things that I would appreciate more input on is the naming convention. This series follows the hidden device naming nvmeXcYnZ, but I am not sure how this will work out with multipath. The concern is if we will have unfixable naming collisions that will jepardize user-space tools depending on this naming. Thanks to Christoph for proposing this in the first place and Christoph and Keith for early reviews of this patchset! Javier Javier González (4): nvme: remove unnecessary return values nvme: rename controller base dev_t char device nvme: rename bdev operations nvme: enable char device per namespace drivers/nvme/host/core.c | 172 ++++++++++++++++++++++++++++++++------- drivers/nvme/host/nvme.h | 3 + 2 files changed, 146 insertions(+), 29 deletions(-) -- 2.17.1