On Tue, Aug 18, 2020 at 01:45:29PM +0800, Baolin Wang wrote: > Meanwhile move the blk_mq_bio_list_merge() into blk-merge.c and > rename it as a generic name. That should probably a separate patch. > + if (blk_attempt_bio_merge(q, rq, bio, nr_segs, false) == BIO_MERGE_OK) > + return true; This adds an overly long line. > - if (merged) > + switch (blk_attempt_bio_merge(q, rq, bio, nr_segs, true)) { > + default: > + case BIO_MERGE_NONE: > + continue; > + case BIO_MERGE_OK: > return true; > + case BIO_MERGE_FAILED: > + return false; > + } I don't think we need a default statement here as we handle all possible values of the enum.