Re: [PATCH] block: add split_alignment for request queue

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



3 minor suggestions, and a larger question:

1) struct queue_limits already contains some alignment information;
e.g. discard_alignment, io_opt; perhaps this would better belong there
instead of in struct request_queue. (This would also move the
Documentation to Documentation/ABI/testing/sysfs-block)
2) Perhaps in parallel to discard_alignment this should be called io_alignment.
3) Documentation has consistent typo 'requeust'->request

Reading through this change, split_alignment appears similar in my
mind to limits->io_opt. But it does not actually appear to be factored
into bio splitting, although it's described as "A properly aligned
multiple of optimal_io_size is the preferred request size for
workloads where sustained throughput is desired"... probably I don't
understand the intended use of limits->io_opt, but it makes me wonder
if perhaps io_opt should be factored into bio splitting instead of
adding a new parameter? I am not very familiar with this area, and I'd
love to know more about what io_opt is for and how this proposal is
different.

Thanks!

John Dorminy




[Index of Archives]     [Linux RAID]     [Linux SCSI]     [Linux ATA RAID]     [IDE]     [Linux Wireless]     [Linux Kernel]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Device Mapper]

  Powered by Linux