On Tue, May 05, 2020 at 07:55:40PM +0800, Zhen Lei wrote: > +#ifndef SECTORS_PER_PAGE_SHIFT > +#define SECTORS_PER_PAGE_SHIFT (PAGE_SHIFT - SECTOR_SHIFT) > +#endif > +#ifndef SECTORS_PER_PAGE > +#define SECTORS_PER_PAGE (1 << SECTORS_PER_PAGE_SHIFT) > #endif I find SECTORS_PER_PAGE_SHIFT quite hard to read. I had a quick skim of your other patches, and it seems to me that we could replace '<< SECTORS_PER_PAGE_SHIFT' with '* SECTORS_PER_PAGE' and it would be more readable in every case.