On Tue, 2020-02-25 at 20:01 +0000, Balbir Singh wrote: > Allow block/genhd to notify user space about disk size changes using a > new helper set_capacity_revalidate_and_notify(), which is a wrapper > on top of set_capacity(). set_capacity_revalidate_and_notify() will only > notify > iff the current capacity or the target capacity is not zero and the > capacity really changes. > > Background: > > As a part of a patch to allow sending the RESIZE event on disk capacity > change, Christoph (hch@xxxxxx) requested that the patch be made generic > and the hacks for virtio block and xen block devices be removed and > merged via a generic helper. > > This series consists of 5 changes. The first one adds the basic > support for changing the size and notifying. The follow up patches > are per block subsystem changes. Other block drivers can add their > changes as necessary on top of this series. Since not all devices > are resizable, the default was to add a new API and let users > slowly convert over as needed. > > Testing: > 1. I did some basic testing with an NVME device, by resizing it in > the backend and ensured that udevd received the event. > > > Changelog v2: > - Rename disk_set_capacity to set_capacity_revalidate_and_notify > - set_capacity_revalidate_and_notify can call revalidate disk > if needed, a new bool parameter is passed (suggested by Bob Liu) > Ping? It's not an urgent patchset, I am happy to wait if nothing else is needed. Balbir Singh