On 1/2/20 5:35 AM, Jinpu Wang wrote:
On Mon, Dec 30, 2019 at 8:25 PM Bart Van Assche <bvanassche@xxxxxxx> wrote:
+/**
+ * enum rtrs_clt_con_type() type of ib connection to use with a given permit
What is a "permit"?
Does use rtrs_permit sound better?
I think keeping the word "permit" is fine. How about adding a comment
above rtrs_permit that explains more clearly what the role of that data
structure is? This is what I found in rtrs-clt.h:
/**
* rtrs_permit - permits the memory allocation for future RDMA operation
*/
struct rtrs_permit {
enum rtrs_clt_con_type con_type;
unsigned int cpu_id;
unsigned int mem_id;
unsigned int mem_off;
};
Thanks,
Bart.