On 2019/9/16 17:06, Christoph Hellwig wrote:
On Mon, Sep 16, 2019 at 07:46:29AM +0530, xiubli@xxxxxxxxxx wrote:
From: Xiubo Li <xiubli@xxxxxxxxxx>
To make the patch more readable and cleaner I just split them into 2
small ones to address the issue from @Ming Lei, thanks very much.
I'd be much happier to just see memalloc_noio_save +
memalloc_noio_restore calls in the right places over sprinkling even
more magic GFP_NOIO arguments.
Hi Christoph,
BTW, then to make the code to be more readable, should I just keep the
BLK_MQ_GFP_GLAGS as:
#define BLK_MQ_GFP_FLAGS (GFP_NOIO | __GFP_NOWARN | __GFP_NORETRY)
Or just switch to:
#define BLK_MQ_GFP_FLAGS (GFP_KERNEL | __GFP_NOWARN | __GFP_NORETRY)
?
Any advice about this ?
Thanks very much,
BRs
Xiubo