My previous submission was an RFC, but I got a reviewed-by from Chaitanya, so I removed the RFc tag. Changes from v1: Reworked the documentation of size_to_sectors by removing a sentence that was explaining the size -> sectors math, which wasn't necessary given the description prior to the example. Let me know if you have more suggestions to this code. Here is the cover letter of the RFC sent prior to this patchset: While reading code of drivers/block, I was curious about the set_capacity argument, always shifting the value by 9, and so I took me a while to realize this is done on purpose: the capacity is the number of sectors of 512 bytes related to the storage space. Rather the shifting by 9, there are other places where the value if shifted by SECTOR_SHIFT, which is more readable. This patch aims to reduce these differences by adding a new function called size_to_sectors, adding a proper comment explaining why this is needed. null_blk was changed to use this new function. Thanks, Marco Marcos Paulo de Souza (2): blkdev.h: Introduce size_to_sectors hlper function null_blk: Make use of size_to_sectors helper drivers/block/null_blk_main.c | 18 +++++++++--------- include/linux/blkdev.h | 17 +++++++++++++++++ 2 files changed, 26 insertions(+), 9 deletions(-) -- 2.16.4