On 11/28/18 12:20 AM, Christoph Hellwig wrote: >> +static inline int nvme_next_ring_index(struct nvme_queue *nvmeq, u16 index) >> +{ >> + if (++index == nvmeq->q_depth) >> + return 0; >> + >> + return index; > > Can you please just drop this helper? It makes the code not only > less readable but also longer. > > Otherwise the change looks fine to me. Alright, dropped the helper. -- Jens Axboe