On Wed, Nov 14, 2018 at 06:56:41PM +0100, Ulf Hansson wrote: > > } else { > > @@ -397,6 +397,7 @@ int mmc_init_queue(struct mmc_queue *mq, struct mmc_card *card, > > int ret; > > > > mq->card = card; > > + mq->lock = lock; > > Unless I am mistaken, it seems like the "lock" can also be removed as > an in-parameter to mmc_init_queue() - and instead do the > spin_lock_init() in here. > > Moreover, that means we should drop the "lock" from the struct > mmc_blk_data and instead move it to struct mmc_queue (rather than > having a pointer to it.) Which sounds like a sensible idead indeed, I'll look into it.