On 10/30/18 6:59 PM, Sagi Grimberg wrote: >> +static inline struct blk_mq_hw_ctx *blk_mq_map_queue(struct request_queue *q, >> + unsigned int flags, >> + unsigned int cpu) >> { >> - return blk_mq_map_queue(q, hctx_type, cpu); >> + int hctx_type = 0; >> + >> + if (q->mq_ops->flags_to_type) >> + hctx_type = q->mq_ops->flags_to_type(q, flags); > > nitpick: I think that rq_flags_to_type is a bit more descriptive here. > just a personal opinion. Sure, I can make that change. -- Jens Axboe