On Mon, 2018-10-29 at 10:37 -0600, Jens Axboe wrote: +AD4 diff --git a/block/blk-mq.h b/block/blk-mq.h +AD4 index 889f0069dd80..79c300faa7ce 100644 +AD4 --- a/block/blk-mq.h +AD4 +-+-+- b/block/blk-mq.h +AD4 +AEAAQA -80,6 +-80,12 +AEAAQA static inline struct blk+AF8-mq+AF8-hw+AF8-ctx +ACo-blk+AF8-mq+AF8-map+AF8-queue(struct request+AF8-queue +ACo-q, +AD4 return q-+AD4-queue+AF8-hw+AF8-ctx+AFs-set-+AD4-map+AFs-0+AF0.mq+AF8-map+AFs-cpu+AF0AXQA7 +AD4 +AH0 +AD4 +AD4 +-static inline struct blk+AF8-mq+AF8-hw+AF8-ctx +ACo-blk+AF8-mq+AF8-map+AF8-queue+AF8-type(struct request+AF8-queue +ACo-q, +AD4 +- int type, int cpu) +AD4 +-+AHs +AD4 +- return blk+AF8-mq+AF8-map+AF8-queue(q, cpu)+ADs +AD4 +-+AH0 +AD4 +- +AD4 /+ACo +AD4 +ACo sysfs helpers +AD4 +ACo-/ How about renaming 'type' into something like hw+AF8-ctx+AF8-type to make it more clear what its meaning is? How about declaring both the 'type' and 'cpu' arguments as unsigned ints? Thanks, Bart.