On 4/10/18 2:45 PM, Bart Van Assche wrote: > Because blkcg_exit_queue() is now called from inside blk_cleanup_queue() > it is no longer safe to access cgroup information during or after the > blk_cleanup_queue() call. Hence protect the generic_make_request_checks() > call with blk_queue_enter() / blk_queue_exit(). This looks better. But can we please get rid of the ternary? I hate it with a vengeance, especially when it ends up spanning multiple lines. This: flags = 0; if (bio->bi_opf & REQ_NOWAIT) flags = BLK_MQ_REQ_NOWAIT; is so much more readable. -- Jens Axboe