> +static inline unsigned int nvme_ioq_vector(struct nvme_dev *dev, > + unsigned int qid) No need for the inline here I think. > +{ > + /* > + * A queue's vector matches the queue identifier unless the controller > + * has only one vector available. > + */ > + return (dev->num_vecs == 1) ? 0 : qid; and no need for the braces here. > + struct irq_affinity affd = {.pre_vectors = 1}; struct irq_affinity affd = { .pre_vectors = 1 }; to make it a little more readable.