On Thu, Dec 14, 2017 at 05:01:06PM +0000, Bart Van Assche wrote: > On Tue, 2017-12-12 at 11:01 -0800, Tejun Heo wrote: > > + } else { > > + srcu_idx = srcu_read_lock(hctx->queue_rq_srcu); > > + if (!blk_mark_rq_complete(rq)) > > + __blk_mq_complete_request(rq); > > + srcu_read_unlock(hctx->queue_rq_srcu, srcu_idx); > > Hello Tejun, > > The name queue_rq_srcu was chosen to reflect the original use of that structure, > namely to protect .queue_rq() calls. Your patch series broadens the use of that Yeah, will add a patch to rename it. > srcu structure so I would appreciate it if it would be renamed, e.g. into "srcu". > See also commit 6a83e74d214a ("blk-mq: Introduce blk_mq_quiesce_queue()"). Ah yeah, it'd be nice to have the [s]rcu synchronize calls factored out. Thanks. -- tejun