On Sat, 2017-08-05 at 14:56 +0800, Ming Lei wrote: > -static inline void sbitmap_for_each_set(struct sbitmap *sb, sb_for_each_fn fn, > - void *data) > +static inline void __sbitmap_for_each_set(struct sbitmap *sb, > + unsigned int off, > + sb_for_each_fn fn, void *data) > { An additional comment: if a function name starts with a double underscore usually that either means that it should be called with a specific lock held or that it is an implementation function that should not be called by other modules. Since neither is the case for __sbitmap_for_each_set(), please consider to use another name for this function. Thanks, Bart.