On Fri, 2017-08-04 at 13:56 -0600, Jens Axboe wrote: > On 08/04/2017 01:44 PM, Bart Van Assche wrote: > > On Fri, 2017-08-04 at 09:04 -0600, Jens Axboe wrote: > > > @@ -98,11 +98,13 @@ static void blk_mq_check_inflight(struct blk_mq_hw_ctx *hctx, > > > return; > > > > > > /* > > > - * Count as inflight if it either matches the partition we asked > > > - * for, or if it's the root > > > + * Count as inflight if it matches the partition, count separately > > > + * (but all) if we got asked for the root > > > */ > > > - if (rq->part == mi->part || mi->part->partno) > > > + if (rq->part == mi->part) > > > mi->inflight[0]++; > > > + if (mi->part->partno) > > > + mi->inflight[1]++; > > > } > > > > Hello Jens, > > > > Same question here: should "if (mi->part->partno)" perhaps be changed into > > "if (mi->part->partno == 0)"? > > It should be correct as-is. Agreed, I got misled by the comment above the code. Bart.