Hi, This patchset contains total three patches. The first patch helps protect debugfs attributes using q->elevator_lock instead of q->sysfs_lock. The second patch in the series removes the goto labels from the read methods of debugfs attributes that improves code readability and reducing complexity. The third patch in the series protects debugfs attribute method hctx_ busy_show using q->elevator_lock. Please note that this patchset was unit tested against blktests and quick xfstests with lockdep enabled. --- Changes from v1: - Split patch into smaller patches for bisectability. (hch) - Remove goto lable and return immediately upon failing to acquire the mutex lock. (Damien, hch) - Original patch in v1 is splitted into three patches Link to v1: https://lore.kernel.org/all/20250312102903.3584358-1-nilay@xxxxxxxxxxxxx/ --- Nilay Shroff (3): block: protect debugfs attrs using elevator_lock instead of sysfs_lock block: Remove unnecessary goto labels in debugfs attribute read methods block: protect debugfs attribute method hctx_busy_show block/blk-mq-debugfs.c | 41 +++++++++++++++++++++-------------------- include/linux/blkdev.h | 6 +++--- 2 files changed, 24 insertions(+), 23 deletions(-) -- 2.47.1