On Mon, Feb 10, 2025 at 09:40:30PM +0100, Borislav Petkov wrote: > On Mon, Feb 10, 2025 at 09:45:35AM -0800, Eric Biggers wrote: > > @@ -1598,11 +1578,11 @@ static int __init register_avx_algs(void) > > ARRAY_SIZE(aes_gcm_algs_vaes_avx10_256), > > aes_gcm_simdalgs_vaes_avx10_256); > > if (err) > > return err; > > > > - if (x86_match_cpu(zmm_exclusion_list)) { > > + if (boot_cpu_has(X86_FEATURE_PREFER_YMM)) { > > s/boot_cpu_has/cpu_feature_enabled/ > $ git grep boot_cpu_has arch/x86/crypto | wc -l 87 $ git grep cpu_feature_enabled arch/x86/crypto | wc -l 0 It wouldn't make sense to change just this one. Should they really all be changed? I see that cpu_feature_enabled() uses code patching while boot_cpu_has() does not. All these checks occur once at module load time, though, so code patching wouldn't be beneficial. - Eric