Hi Jens, This patch series includes: - One patch with a micro-optimization for blk_mq_submit_bio(). - Two patches that improve blk_mq_submit_bio() readability by moving error handling code into blk_mq_submit_bio(). Please consider this patch series for the next merge window. Thanks, Bart. Changes compared to v1 of this patch series: - Addressed Christoph's comments on patch 2/3. - Added patch 3/3 to this series. Bart Van Assche (3): block: Optimize blk_mq_submit_bio() for the cache hit scenario blk-mq: Move more error handling into blk_mq_submit_bio() blk-zoned: Move more error handling into blk_mq_submit_bio() block/blk-mq.c | 36 +++++++++++++++-------- block/blk-zoned.c | 67 +++++++++++++++++++----------------------- include/linux/blkdev.h | 13 ++++++-- 3 files changed, 66 insertions(+), 50 deletions(-)