On Tue, Jun 18, 2024 at 10:00:08AM +0800, Ming Lei wrote: > > + /* forbid nonsense combinations of recovery flags */ > > + switch (info.flags & UBLK_F_ALL_RECOVERY_FLAGS) { > > + case 0: > > + case UBLK_F_USER_RECOVERY: > > + case (UBLK_F_USER_RECOVERY | UBLK_F_USER_RECOVERY_REISSUE): > > + break; > > + default: > > + pr_warn("%s: invalid recovery flags %llx\n", __func__, > > + info.flags & UBLK_F_ALL_RECOVERY_FLAGS); > > + return -EINVAL; > > + } > > + > > It could be cleaner and more readable to check the fail condition only: > > if ((info.flags & UBLK_F_USER_RECOVERY_REISSUE) && > !(info.flags & UBLK_F_USER_RECOVERY)) { > ... > } Will do. But note that in patch 4 this check gets more complex so we may change it back to a switch statement.