Hello, Please, add a small commit message to the patch. The commit title is too long and can be reduced to something like "floppy: remove duplicated code in redo_fd_request()". Rest can be added to the commit message. On 3/18/24 10:07, Yufeng Wang wrote: > Cc: stable@xxxxxxxxxxxxxxx We don't need to send this patch to stable. It's not a bugfix. Please, send v2 with commit message and new title. The change looks good to me. > Signed-off-by: Yufeng Wang <wangyufeng@xxxxxxxxxx> > --- > drivers/block/floppy.c | 1 - > 1 file changed, 1 deletion(-) > > diff --git a/drivers/block/floppy.c b/drivers/block/floppy.c > index 1b399ec8c07d..25c9d85667f1 100644 > --- a/drivers/block/floppy.c > +++ b/drivers/block/floppy.c > @@ -2787,7 +2787,6 @@ static void redo_fd_request(void) > pending = set_next_request(); > spin_unlock_irq(&floppy_lock); > if (!pending) { > - do_floppy = NULL; > unlock_fdc(); > return; > } Thanks, Denis