On Mon, Feb 26, 2024 at 05:49:30PM +0100, Stefan Haberland wrote: > Could we call this dasd_*_max_sectors() or something like this? Sure. >> - blk_queue_max_segment_size(q, PAGE_SIZE); >> - blk_queue_segment_boundary(q, PAGE_SIZE - 1); >> - blk_queue_dma_alignment(q, PAGE_SIZE - 1); >> + return DIAG_MAX_BLOCKS; > > You are dropping the shift here (and in the other discipline cases). This > might lead to smaller request sizes and decreased performance. > Should be: > > return DIAG_MAX_BLOCKS << block->s2b_shift; I actually wanted to move the shift to the caller, but forgot to add it there. But with the max_sectors naming it's probably better to keep it in the disciplines.