> +void invalidate_bdev_range(struct block_device *bdev, pgoff_t start, > + pgoff_t end) > +{ > + invalidate_mapping_pages(bdev->bd_inode->i_mapping, start, end); > +} > +EXPORT_SYMBOL_GPL(invalidate_bdev_range); Can we have kerneldoc comments for the new helpers please? > +struct folio *__bdev_get_folio(struct block_device *bdev, loff_t pos, > + fgf_t fgp_flags, gfp_t gfp) > +{ > + return __filemap_get_folio(bdev->bd_inode->i_mapping, pos >> PAGE_SHIFT, > + fgp_flags, gfp); > +} > +EXPORT_SYMBOL_GPL(__bdev_get_folio); It's a bit silly to have a __-prefixed API without a version that doesn't have the prefix, so I'd prefer to drop it. Unless willy has a good argument for keeping it the same as the filemap API.