On Fri, Dec 02, 2016 at 08:15:15PM -0700, Jens Axboe wrote: > No functional changes with this patch, it's just in preparation for > supporting legacy schedulers on blk-mq. Ewww. I think without refactoring to clear what 'use_mq_path' means here and better naming this is a total non-started. Even with that we'll now have yet another code path to worry about. Is there any chance to instead consolidate into a single path? > struct request *blk_get_request(struct request_queue *q, int rw, gfp_t gfp_mask) > { > - if (q->mq_ops) > + if (blk_use_mq_path(q)) > return blk_mq_alloc_request(q, rw, > (gfp_mask & __GFP_DIRECT_RECLAIM) ? > 0 : BLK_MQ_REQ_NOWAIT); So now with blk-mq and an elevator set we go into blk_old_get_request, hich will simply allocate new requests. How does this not break every existing driver? -- To unsubscribe from this list: send the line "unsubscribe linux-block" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html