On Sun, May 23, 2021 at 10:10:34AM +0200, Hannes Reinecke wrote: > Can't these conditionals be merged into a single 'if (md->disk)'? > Eg like: > > if (md->disk) { > spin_lock(&_minor_lock); > md->disk->private_data = NULL; > spin_unlock(&_minor_lock); > del_gendisk(md->disk); > dm_queue_destroy_keyslot_manager(md->queue); > blk_cleanup_disk(md->queue); > } > > We're now always allocating 'md->disk' and 'md->queue' together, > so how can we end up in a situation where one is set without the other? I guess we could do that, not sure it is worth the churn, though.