On Wed, Mar 03, 2021 at 02:22:36PM +0100, Arnaud POULIQUEN wrote: > Hi Mathieu, > > On 3/2/21 6:57 PM, Mathieu Poirier wrote: > > Good morning, > > > > I have started to review this set - comments will be staggered over several > > days. > > > > On Fri, Feb 19, 2021 at 12:14:49PM +0100, Arnaud Pouliquen wrote: > >> To prepare the split code related to the control and the endpoint > >> devices in separate files: > >> - suppress the dependency with the rpmsg_ctrldev struct, > >> - rename and export the functions in rpmsg_char.h. > >> > >> Suggested-by: Mathieu Poirier <mathieu.poirier@xxxxxxxxxx> > >> Signed-off-by: Arnaud Pouliquen <arnaud.pouliquen@xxxxxxxxxxx> > >> --- > >> drivers/rpmsg/rpmsg_char.c | 22 ++++++++++------ > >> drivers/rpmsg/rpmsg_char.h | 51 ++++++++++++++++++++++++++++++++++++++ > >> 2 files changed, 66 insertions(+), 7 deletions(-) > >> create mode 100644 drivers/rpmsg/rpmsg_char.h > >> > >> diff --git a/drivers/rpmsg/rpmsg_char.c b/drivers/rpmsg/rpmsg_char.c > >> index 9e33b53bbf56..78a6d19fdf82 100644 > >> --- a/drivers/rpmsg/rpmsg_char.c > >> +++ b/drivers/rpmsg/rpmsg_char.c > >> @@ -1,5 +1,6 @@ > >> // SPDX-License-Identifier: GPL-2.0 > >> /* > >> + * Copyright (C) 2021, STMicroelectronics > >> * Copyright (c) 2016, Linaro Ltd. > >> * Copyright (c) 2012, Michal Simek <monstr@xxxxxxxxx> > >> * Copyright (c) 2012, PetaLogix > >> @@ -22,6 +23,7 @@ > >> #include <linux/uaccess.h> > >> #include <uapi/linux/rpmsg.h> > >> > >> +#include "rpmsg_char.h" > >> #include "rpmsg_internal.h" > >> > >> #define RPMSG_DEV_MAX (MINORMASK + 1) > >> @@ -78,7 +80,7 @@ struct rpmsg_eptdev { > >> wait_queue_head_t readq; > >> }; > >> > >> -static int rpmsg_eptdev_destroy(struct device *dev, void *data) > >> +static int rpmsg_eptdev_destroy(struct device *dev) > >> { > >> struct rpmsg_eptdev *eptdev = dev_to_eptdev(dev); > >> > >> @@ -277,7 +279,7 @@ static long rpmsg_eptdev_ioctl(struct file *fp, unsigned int cmd, > >> if (cmd != RPMSG_DESTROY_EPT_IOCTL) > >> return -EINVAL; > >> > >> - return rpmsg_eptdev_destroy(&eptdev->dev, NULL); > >> + return rpmsg_eptdev_destroy(&eptdev->dev); > >> } > >> > >> static const struct file_operations rpmsg_eptdev_fops = { > >> @@ -336,10 +338,15 @@ static void rpmsg_eptdev_release_device(struct device *dev) > >> kfree(eptdev); > >> } > >> > >> -static int rpmsg_eptdev_create(struct rpmsg_ctrldev *ctrldev, > >> +int rpmsg_chrdev_eptdev_destroy(struct device *dev, void *data) > >> +{ > >> + return rpmsg_eptdev_destroy(dev); > >> +} > >> +EXPORT_SYMBOL(rpmsg_chrdev_eptdev_destroy); > > > > Below we have rpmsg_chrdev_create_eptdev() so it would make sense to have > > rpmsg_chrdev_destroy_ept(). > > > > I would also rename rpmsg_eptdev_destroy() to rpmsg_chrdev_destroy_ept() and > > export that symbol rather than introducing a function that only calls another > > one. You did exactly that for rpmsg_chrdev_create_eptdev(). > > This function is used in rpmsg_ctrl to remove eptdev devices. > As device_for_each_child request a specific function prototype I do not only > export but change function prototype. > > I can squash all in one function but that means that the "data" parameter is > just always unused. The @data parameter in rpmsg_eptdev_destroy() is currently unused so nothing changes. > > > > >> + > >> +int rpmsg_chrdev_create_eptdev(struct rpmsg_device *rpdev, struct device *parent, > >> struct rpmsg_channel_info chinfo) > >> { > >> - struct rpmsg_device *rpdev = ctrldev->rpdev; > >> struct rpmsg_eptdev *eptdev; > >> struct device *dev; > >> int ret; > >> @@ -359,7 +366,7 @@ static int rpmsg_eptdev_create(struct rpmsg_ctrldev *ctrldev, > >> > >> device_initialize(dev); > >> dev->class = rpmsg_class; > >> - dev->parent = &ctrldev->dev; > >> + dev->parent = parent; > >> dev->groups = rpmsg_eptdev_groups; > >> dev_set_drvdata(dev, eptdev); > >> > >> @@ -402,6 +409,7 @@ static int rpmsg_eptdev_create(struct rpmsg_ctrldev *ctrldev, > >> > >> return ret; > >> } > >> +EXPORT_SYMBOL(rpmsg_chrdev_create_eptdev); > >> > >> static int rpmsg_ctrldev_open(struct inode *inode, struct file *filp) > >> { > >> @@ -441,7 +449,7 @@ static long rpmsg_ctrldev_ioctl(struct file *fp, unsigned int cmd, > >> chinfo.src = eptinfo.src; > >> chinfo.dst = eptinfo.dst; > >> > >> - return rpmsg_eptdev_create(ctrldev, chinfo); > >> + return rpmsg_chrdev_create_eptdev(ctrldev->rpdev, &ctrldev->dev, chinfo); > > > > Not sure why we have to change the signature of rpmsg_eptdev_create() but I may > > find an answer to that question later on in the patchset. > > Here I need to break dependency with rpmsg_ctrldev that will move to the > rpmsg_ctrl.c. rpmsg_eptdev_create doesn't need it but just parent devices to be > attached to. So you don't want to have instances of struct rpmsg_ctrldev in rpmsg_char.c . Ok, that's a valid point. > > I will add more explicit information about this, in the commit message. > > Thanks, > Arnaud > > > > >> }; > >> > >> static const struct file_operations rpmsg_ctrldev_fops = { > >> @@ -527,7 +535,7 @@ static void rpmsg_chrdev_remove(struct rpmsg_device *rpdev) > >> int ret; > >> > >> /* Destroy all endpoints */ > >> - ret = device_for_each_child(&ctrldev->dev, NULL, rpmsg_eptdev_destroy); > >> + ret = device_for_each_child(&ctrldev->dev, NULL, rpmsg_chrdev_eptdev_destroy); > >> if (ret) > >> dev_warn(&rpdev->dev, "failed to nuke endpoints: %d\n", ret); > >> > >> diff --git a/drivers/rpmsg/rpmsg_char.h b/drivers/rpmsg/rpmsg_char.h > >> new file mode 100644 > >> index 000000000000..0feb3ea9445c > >> --- /dev/null > >> +++ b/drivers/rpmsg/rpmsg_char.h > >> @@ -0,0 +1,51 @@ > >> +/* SPDX-License-Identifier: GPL-2.0 WITH Linux-syscall-note */ > >> +/* > >> + * Copyright (C) STMicroelectronics 2021. > >> + */ > >> + > >> +#ifndef __RPMSG_CHRDEV_H__ > >> +#define __RPMSG_CHRDEV_H__ > >> + > >> +#if IS_ENABLED(CONFIG_RPMSG_CHAR) > >> +/** > >> + * rpmsg_chrdev_create_eptdev() - register char device based on an endpoint > >> + * @rpdev: prepared rpdev to be used for creating endpoints > >> + * @parent: parent device > >> + * @chinfo: assiated endpoint channel information. > >> + * > >> + * This function create a new rpmsg char endpoint device to instantiate a new > >> + * endpoint based on chinfo information. > >> + */ > >> +int rpmsg_chrdev_create_eptdev(struct rpmsg_device *rpdev, struct device *parent, > >> + struct rpmsg_channel_info chinfo); > >> + > >> +/** > >> + * rpmsg_chrdev_eptdev_destroy() - destroy created char device > >> + * @data: parent device > >> + * @chinfo: assiated endpoint channel information. > >> + * > >> + * This function create a new rpmsg char endpoint device to instantiate a new > >> + * endpoint based on chinfo information. > >> + */ > >> +int rpmsg_chrdev_eptdev_destroy(struct device *dev, void *data); > >> + > >> +#else /*IS_ENABLED(CONFIG_RPMSG_CHAR) */ > >> + > >> +static inline int rpmsg_chrdev_create_eptdev(struct rpmsg_device *rpdev, > >> + struct device *parent, > >> + struct rpmsg_channel_info chinfo) > >> +{ > >> + return -EINVAL; > >> +} > >> + > >> +static inline int rpmsg_chrdev_eptdev_destroy(struct device *dev, void *data) > >> +{ > >> + /* This shouldn't be possible */ > >> + WARN_ON(1); > >> + > >> + return 0; > >> +} > >> + > >> +#endif /*IS_ENABLED(CONFIG_RPMSG_CHAR) */ > >> + > >> +#endif /*__RPMSG_CHRDEV_H__ */ > >> -- > >> 2.17.1 > >>