On Sun, Sep 20, 2020 at 2:19 AM Andrew Lunn <andrew@xxxxxxx> wrote: > > > + > > +/* 0 = Clause 22, 1 = Clause 45 */ > > +#define MDIO_MODE_BIT BIT(8) > > How about calling this MDIO_MODE_C45 Good idea, will rename it. > > > + /* Enter Clause 45 mode */ > > + data = readl(priv->membase + MDIO_MODE_REG); > > + > > + data |= MDIO_MODE_BIT; > > + > > + writel(data, priv->membase + MDIO_MODE_REG); > > It then becomes clearer what this does. > > Otherwise this looks O.K. > > Andrew v4 has been pushed to address your comment Regards, Robert