On 8/25/2020 5:25 PM, Rob Herring wrote:
On Tue, Aug 18, 2020 at 11:54:14AM -0700, Elliot Berman wrote:
Current reboot-mode device tree schema does not support reboot commands
with spaces in them [1]. Add an optional new node "reboot-mode-names"
and "reboot-mode-magic" which add an array of strings and u32s,
respectively which would permit any string in this framework.
Kind of a weak justification. The intent was for the names to be a key,
not a multi word description which your example seems to be. Is
"dm-verity device corrupted" something Android has already standardized
on?
+Eric/Sami to comment further
I wonder if you're thinking it's better to change the kernel_restart in
dm-verity-target.c?
Alternatively, I could respin so that spaces in the reboot cmd is
replaced with "-" in reboot_mode_notify(). This way, there is no need to
change dm-verity driver or change devicetree schema. i.e.:
@@ -44,9 +44,13 @@ static int reboot_mode_notify(struct notifier_block
*this,
{
struct reboot_mode_driver *reboot;
unsigned int magic;
+ char *reboot_cmd;
+
+ reboot_cmd = kstrdup(cmd, GFP_KERNEL);
+ strreplace(reboot_cmd, ' ', '-');
reboot = container_of(this, struct reboot_mode_driver,
reboot_notifier);
- magic = get_reboot_mode_magic(reboot, cmd);
+ magic = get_reboot_mode_magic(reboot, reboot_cmd);
if (magic)
reboot->write(reboot, magic);
[1]:
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/drivers/md/dm-verity-target.c?h=v5.5#n255
Signed-off-by: Elliot Berman <eberman@xxxxxxxxxxxxxx>
---
.../devicetree/bindings/power/reset/reboot-mode.yaml | 17 +++++++++++++++++
1 file changed, 17 insertions(+)
diff --git a/Documentation/devicetree/bindings/power/reset/reboot-mode.yaml b/Documentation/devicetree/bindings/power/reset/reboot-mode.yaml
index a6c9102..4ea6b33 100644
--- a/Documentation/devicetree/bindings/power/reset/reboot-mode.yaml
+++ b/Documentation/devicetree/bindings/power/reset/reboot-mode.yaml
@@ -19,6 +19,9 @@ description: |
the bootloader what to do when the system reboots, and should be named
as mode-xxx = <magic> (xxx is mode name, magic should be a non-zero value).
+ reboot-mode-magic and reboot-mode-names may be used in addition/instead of
+ mode-xxx style.
It should be either/or in my opinion, not both.
OK, I can fix in the next patch.
+
For example, modes common Android platform are:
- normal: Normal reboot mode, system reboot with command "reboot".
- recovery: Android Recovery mode, it is a mode to format the device or update a new image.
@@ -32,6 +35,14 @@ properties:
description: |
Default value to set on a reboot if no command was provided.
+ reboot-mode-names:
+ $ref: /schemas/types.yaml#/definitions/string-array
+ description: List of reboot commands, paired with reboot-mode-magic by index
+
+ reboot-mode-magic:
'reboot-modes' would align with normal patterns.
Ditto
+ $ref: /schemas/types.yaml#/definitions/uint32-array
+ description: List of reboot magic, paired with reboot-mode-names by index
+
patternProperties:
"^mode-.*$":
$ref: /schemas/types.yaml#/definitions/uint32
@@ -44,4 +55,10 @@ examples:
mode-bootloader = <2>;
mode-loader = <3>;
};
+
+ - |
+ reboot-mode {
+ reboot-mode-names = "normal", "bootloader", "dm-verity device corrupted";
+ reboot-mode-magic = <0x0>, <0x1>, <0xf>;
+ };
...
--
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum,
a Linux Foundation Collaborative Project