Re: [PATCH v8 4/4] arm64: boot: dts: qcom: pm8150b: Add DTS node for PMIC VBUS booster

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 20.08.2020 10:47, Wesley Cheng wrote:

[...]
Add the required DTS node for the USB VBUS output regulator, which is
available on PM8150B.  This will provide the VBUS source to connected
peripherals.

Signed-off-by: Wesley Cheng <wcheng@xxxxxxxxxxxxxx>
---
   arch/arm64/boot/dts/qcom/pm8150b.dtsi   | 6 ++++++
   arch/arm64/boot/dts/qcom/sm8150-mtp.dts | 4 ++++
   2 files changed, 10 insertions(+)

diff --git a/arch/arm64/boot/dts/qcom/pm8150b.dtsi
b/arch/arm64/boot/dts/qcom/pm8150b.dtsi
index 053c659734a7..9e560c1ca30d 100644
--- a/arch/arm64/boot/dts/qcom/pm8150b.dtsi
+++ b/arch/arm64/boot/dts/qcom/pm8150b.dtsi
@@ -53,6 +53,12 @@ power-on@800 {
               status = "disabled";
           };
   +        pm8150b_vbus: dcdc@1100 {

    s/dcdc/regulator/? What is "dcdc", anyway?
    The device nodes must have the generic names, according to the DT spec.


Hi Sergei,

Thanks for the comment!

    You're welcome.

DCDC is the label that we use for the DC to DC converter block, since
the VBUS booster will output 5V to the connected devices.  Would it make
more sense to have "dc-dc?"

Better use s/th like "regulator-dcdc". As I said, the names should be generic, reflecting the device class.

Thanks
Wesley

+            compatible = "qcom,pm8150b-vbus-reg";
+            status = "disabled";
+            reg = <0x1100>;
+        };
+
           pm8150b_typec: typec@1500 {
               compatible = "qcom,pm8150b-usb-typec";
               status = "disabled";
[...]

MBR, Sergei



[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [Linux for Sparc]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux