On Mon, 2020-04-13 at 14:18 -0700, Doug Anderson wrote: > Hi, Rehi. > On Mon, Apr 13, 2020 at 11:21 AM Joe Perches <joe@xxxxxxxxxxx> wrote: > > On Mon, 2020-04-13 at 10:04 -0700, Douglas Anderson wrote: > > > This patch makes two changes, both of which should be no-ops: > > > > > > 1. Make read_tcs_reg() / read_tcs_cmd() symmetric to write_tcs_reg() / > > > write_tcs_cmd(). > > > > > > 2. Change the order of operations in the above functions to make it > > > more obvious to me what the math is doing. Specifically first you > > > want to find the right TCS, then the right register, and then > > > multiply by the command ID if necessary. > > > > Though these operations are only used a couple times, perhaps > > it'd be useful to have static inlines for the calcs. > > > > > diff --git a/drivers/soc/qcom/rpmh-rsc.c b/drivers/soc/qcom/rpmh-rsc.c > > [] > > > @@ -67,28 +67,33 @@ > > > #define CMD_STATUS_ISSUED BIT(8) > > > #define CMD_STATUS_COMPL BIT(16) > > > > Maybe something like: > > > > static inline void __iomem * > > tcs_reg_addr(struct rsc_drv drv, int reg, int tcs_id) > > { > > return drv->tcs_base + RSC_DRV_TCS_OFFSET * tcs_id + reg; > > } > > > > static inline void __iomem * > > tcs_cmd_addr(struct rsc_drv drv, int reg, int tcs_id, int cmd_id) > > { > > return tcs_reg_addr(drv, reg, tcs_id) + RSC_DRV_CMD_OFFSET * cmd_id; > > } > > > > > -static u32 read_tcs_reg(struct rsc_drv *drv, int reg, int tcs_id, int cmd_id) > > > +static u32 read_tcs_cmd(struct rsc_drv *drv, int reg, int tcs_id, int cmd_id) > > > { > > > - return readl_relaxed(drv->tcs_base + reg + RSC_DRV_TCS_OFFSET * tcs_id + > > > + return readl_relaxed(drv->tcs_base + RSC_DRV_TCS_OFFSET * tcs_id + reg + > > > RSC_DRV_CMD_OFFSET * cmd_id); > > > > return readl_relaxed(tcs_cmd_addr(drv, reg, tcs_id, cmd_id)); > > > > etc... > > I won't object if you really feel passionately about making that > change but at this point it doesn't add tons of extra readability for > me personally. Just a suggestion. > I was kinda hoping that Maulik and my series could > land in the next few days since having 16 patches outstanding gets a > bit unwieldy. I'd rather not send out another spin of my series at > this point since it's just a bunch more churn in everyone's inboxes. > Maybe after they land you can post that as a follow-up cleanup? If I remember... cheers, Joe