Quoting Matthias Kaehlcke (2020-03-11 09:17:26) > Hi, > > On Wed, Mar 11, 2020 at 08:03:27AM -0700, Doug Anderson wrote: > > Hi, > > > > On Wed, Mar 11, 2020 at 1:47 AM Maulik Shah <mkshah@xxxxxxxxxxxxxx> wrote: > > > > > > Hi, > > > > > > On 3/7/2020 5:29 AM, Douglas Anderson wrote: > > > > This patch makes two changes, both of which should be no-ops: > > > > > > > > 1. Make read_tcs_reg() / read_tcs_cmd() symmetric to write_tcs_reg() / > > > > write_tcs_cmd(). > > > > > > i agree that there are two different write function doing same thing except last addition (RSC_DRV_CMD_OFFSET * cmd_id) > > > > > > can you please rename write_tcs_cmd() to write_tcs_reg(), add above operation in it, and then remove existing write_tcs_reg(). > > > this way we have only one read and one write function. > > > > > > so at the end we will two function as, > > > > > > static u32 read_tcs_reg(struct rsc_drv *drv, int reg, int tcs_id, int cmd_id) > > > { > > > return readl_relaxed(drv->tcs_base + reg + RSC_DRV_TCS_OFFSET * tcs_id + > > > RSC_DRV_CMD_OFFSET * cmd_id); > > > } > > > > > > static void write_tcs_reg(struct rsc_drv *drv, int reg, int tcs_id, int cmd_id, > > > u32 data) > > > { > > > writel_relaxed(data, drv->tcs_base + reg + RSC_DRV_TCS_OFFSET * tcs_id + > > > RSC_DRV_CMD_OFFSET * cmd_id); > > > } > > > > I can if you insist and this is still better than the existing > > (inconsistent) code. > > > > ...but I still feel that having two functions adds value here. > > > > > > Anyone else who is CCed want to weigh in and tie break? > > I agree with Doug, having two functions makes the code that calls them > clearer. It makes it evident when a command is read/written and doesn't require > a useless extra parameter when accessing a non-command register. Me too! In fact, I asked for this when this driver was introduced and I was half-ignored[1]. Making sure we never have to pass 0 to one of these functions should be a goal. >From two years ago: > > Is m the type of TCS (sleep, active, wake) and n is just an offset? > Maybe you can replace m with 'tcs_type' and n with 'index' or 'i' or > 'offset'. And then don't use this function to write the random TCS > registers that don't have to do with the TCS command slots? I see > various places where there are things like: > > > + write_tcs_reg(drv, RSC_DRV_CMD_ENABLE, m, 0, 0); > > + write_tcs_reg(drv, RSC_DRV_CMD_WAIT_FOR_CMPL, m, 0, cmd_complete); > > + write_tcs_reg(drv, RSC_DRV_CMD_ENABLE, m, 0, cmd_enable); > > And 'n' is 0, meaning you rely on that 0 killing that last part of the > equation (RSC_DRV_CMD_OFFSET * n). But if we had a write_tcs_reg(drv, > reg, m, data) and a write_tcs_cmd(drv, reg, m, n, data) then it would be > clearer. > > Even better, add a void *base to a 'struct tcs' and then pass that > struct to the tcs_read/write APIs and then have that pull out a > tcs->base + reg or tcs->base + reg + RSC_DRV_CMD_OFFSET * index. > [1] https://lore.kernel.org/linux-arm-msm/152364140661.51482.261490347611407195@xxxxxxxxxxxxxxxxxxxxxxxxxx/