On Thu, Oct 24, 2019 at 06:10:09PM +0200, Ulf Hansson wrote: > On Thu, 24 Oct 2019 at 17:18, Sudeep Holla <sudeep.holla@xxxxxxx> wrote: > > > > Instead of allocating 'n-1' states in psci_power_state to manage 'n' > > idle states which include "ARM WFI" state, it would be simpler to have > > 1:1 mapping between psci_power_state and cpuidle driver states. > > > > ARM WFI state(i.e. idx == 0) is handled specially in the generic macro > > CPU_PM_CPU_IDLE_ENTER_PARAM and hence state[-1] is not possible. However > > for sake of code readability, it is better to have 1:1 mapping and not > > use [idx - 1] to access psci_power_state corresponding to driver cpuidle > > state for idx. > > > > psci_power_state[0] is default initialised to 0 and is never accessed > > while entering WFI state. > > > > Signed-off-by: Sudeep Holla <sudeep.holla@xxxxxxx> > > Reported-by: Ulf Hansson <ulf.hansson@xxxxxxxxxx> > Reviewed-by: Ulf Hansson <ulf.hansson@xxxxxxxxxx> > > > --- > > drivers/cpuidle/cpuidle-psci.c | 8 +++++--- > > 1 file changed, 5 insertions(+), 3 deletions(-) > > > > Hi Ulf, Lorenzo, > > > > Just to avoid confusion, I thought I will just write this patch as I was > > about to make reference to this in my review. > > As discussed with Lorenzo, I said I was going to adopt his review > comments, which means I already have a patch for this locally. > > Nevermind this time, but I would appreciate if this kind of > bikeshedding can been avoided future wise. > That's one of the reason I just wrote the patch as I felt describing it it words was difficult compared to patch :). Sorry if you felt this was bikeshedding. -- Regards, Sudeep