[v2 PATCH 0/5] drm/msm/gpu: Code reorganization ahead of a6xx

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



In anticipation of forthcoming a6xx support here is a handful of changes to
reorganize the generic code a bit to make it easier to plug in the new target.
Also included are a few minor bug fixes for issues that popped up in the midst
of the new code development.

Resending because I messed up a email address and used my personal email
by accident on another change.

[v2 - fix messed up emails ]
Jordan Crouse (5):
  drm/msm/adreno: Make microcode loading target specific
  drm/msm/adreno: Use generic function to load firwmare to a buffer object
  drm/msm/gpu: Set number of clocks to 0 if the list allocation fails
  drm/msm: Pass the correct aperture end to drm_mm_init
  drm/msm/adreno: Rename gpmufw to powerfw

 drivers/gpu/drm/msm/adreno/a3xx_gpu.c      | 83 ++++++++++++++++++++----------
 drivers/gpu/drm/msm/adreno/a3xx_gpu.h      |  2 +
 drivers/gpu/drm/msm/adreno/a4xx_gpu.c      | 69 ++++++++++++++++++-------
 drivers/gpu/drm/msm/adreno/a4xx_gpu.h      |  2 +
 drivers/gpu/drm/msm/adreno/a5xx_gpu.c      | 26 ++--------
 drivers/gpu/drm/msm/adreno/a5xx_power.c    |  2 +-
 drivers/gpu/drm/msm/adreno/adreno_device.c |  2 +-
 drivers/gpu/drm/msm/adreno/adreno_gpu.c    | 43 ++++++++--------
 drivers/gpu/drm/msm/adreno/adreno_gpu.h    |  7 ++-
 drivers/gpu/drm/msm/msm_gem_vma.c          |  4 +-
 drivers/gpu/drm/msm/msm_gpu.c              |  4 +-
 11 files changed, 146 insertions(+), 98 deletions(-)

-- 
1.9.1

--
To unsubscribe from this list: send the line "unsubscribe linux-arm-msm" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [Linux for Sparc]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux